Fixing NuGet 'Version conflict' errors with Android Support libraries in Xamarin projects

Android

Video is ready, Click Here to View ×


A lot of developers run into errors when trying to update or install NuGet packages in their Xamarin projects, especially in Xamarin.Android projects involving Android Support Libraries. This video is meant to help walk through why this is happening, and what you can do to easily fix the errors and get back to coding.

2 thoughts on “Fixing NuGet 'Version conflict' errors with Android Support libraries in Xamarin projects

  1. i am trying to install sqllite package from nuget but i always get the same error
    the error
    package restore faild
    Severity Code Description Project File Line Suppression State
    Error NU1202 Package NDbUnit.Core 1.6.7 is not compatible with monoandroid81 (MonoAndroid,Version=v8.1). Package NDbUnit.Core 1.6.7 supports: net35 (.NETFramework,Version=v3.5) TestApp C:UsersAhmed SsourcereposTestAppTestAppTestApp.csproj 1

    please heeeeeeeeeeeeeeeeelp i will suicide soon .. pleas i that makes me go crazy

  2. Nice video. Unfortunately, after following it, I am still stuck. I cannot install xamarin.android.support.compat due to this error:
    Package Xamarin.Android.Support.Compat 27.0.2.1 is not compatible with netstandard2.0 (.NETStandard,Version=v2.0). Package Xamarin.Android.Support.Compat 27.0.2.1 supports: monoandroid81 (MonoAndroid,Version=v8.1)

    I can't uninstall or upgrade netstandard2.0, and I can't even find anthing called monoandroid81 or monoandroid.

Leave a Reply

Your email address will not be published. Required fields are marked *