How to Resolve Incompatible Java version Error in Eclipse

Java

Video is ready, Click Here to View ×


I have installed both java 1.6 and 1.7 on my ubuntu developer machine and when i am trying to do some GUI designing using Google WindowBuilder extension for eclipse i ran in to a problem where eclipse fail to load the GUI design view and gave me this error

“Incompatible Java Version

“Eclipse is running under 1.6, but this java project has a 1.7 java compliance level, so windowBuilder will not be able to classes from this project. use a lower level of java for the project, or run eclipse…

24 thoughts on “How to Resolve Incompatible Java version Error in Eclipse

  1. It worked! Thanks a lot! I'm a windows user and at first it didn't work, it showed the console and stuff, so i tried putting:

    -vm
    C:Program Files Javajdk1.7.0_21bin

    and it worked! 😀 thank you very much!

  2. I try the same in windows but doesn't work =(
    I added:
    -vm
    C:Program FilesJavajdk1.7.0_21binjava
    in eclipse.ini
    and when I open eclipse, it open a console but then say "Java was started but returned exit code=-1073741510 ….." and doesn't start

    help!

  3. When doing this, Eclipse will give me the following error (Mac OS X):
    "the jvm shared library does not contain the jni_createjavavm symbol"
    In Eclipse I am using the 1.7 compiler and all that. Anyone how knows how to fix this?

Leave a Reply

Your email address will not be published. Required fields are marked *